Best daily deals

Affiliate links on Android Authority may earn us a commission. Learn more.

Recent Google Pixel phones have a bizarre camera bug

How bizarre. The bug rears its head at 1x but not at 0.9x or 1.1x.
By
February 8, 2024
New pixel camera app interface on Google Pixel 7 Pro.
Rita El Khoury / Android Authority
TL;DR
  • A recent Pixel camera bug means that tapping to set the exposure doesn’t work properly in the camera viewfinder.
  • The issue only seems to appear when shooting at 1x, as the viewfinder shows automatic exposure adjustments at other zoom levels.
  • It does seem like 1x images are still captured with the desired exposure, though.

Google’s Pixel phones are generally among the best camera phones around, owing to the company’s great image processing and variety of computational photography features. However, it looks like a weird bug is affecting the Pixel camera app.

Redditor Ok_Conclusion_1463 (h/t: Android Police) and other users discovered that their Pixel 8 Pro camera’s viewfinder doesn’t automatically adjust exposure based on your tap. That is, tapping on a dark part of the scene is supposed to result in a brighter overall scene while tapping on a bright part of the scene is supposed to result in a darker overall scene.

The Redditor noted that they’re running v9.2.113.585804376.14 of the camera app and that this issue only seems to affect 1x zoom. The automatic exposure adjustments are correctly reflected in the viewfinder when using other zoom levels (e.g. ultrawide, 1.1x, 2x, 5x). The issue also doesn’t pop up when shooting at 16:9 at 1x.

We can confirm seeing this issue on the Pixel 8 and Pixel 8 Pro running the same camera app version. I’m also seeing this issue on my Pixel 7 Pro (see the video above) while at least one Redditor experienced this bug on the vanilla Pixel 7. So it looks like this problem is more widespread than first thought. We weren’t able to reproduce the issue on the Pixel 7a, though.

Are you seeing this camera bug on your Pixel?

45 votes

It’s worth noting that this problem only seems to affect the viewfinder. The 1x images I’ve captured still seem to reflect the desired exposure level. This is still a notable bug, though, as you have to blindly trust that your 1x images will have the correct exposure.