Zoom Meetings on smartphone next to office equipment stock 5

Credit: Edgar Cervantes / Android Authority

Zoom has made several improvements to the overall security of the video conferencing platform over the past few weeks. The company is now asking users to make sure their Zoom applications — be it on smartphones or desktops — are updated to the latest version before May 30.

Zoom wrote in a recent blog post that the update is mandatory for all users. Those who fail to get the latest version of Zoom will not be able to join any meetings after May 30.

Which Zoom update do you need and why?

You require Zoom version 5.0 or higher to be able to join meetings after May 30.

Zoom 5.0 was an important release for the video chatting platform and was introduced in April as part of the company’s 90-day security enhancement plan. It includes a stronger encryption standard to further ensure that the content you share on Zoom cannot be intercepted by people outside your meeting. It also intends to protect users against actions like Zoombombing.

When the update was first released, Zoom noted that it’ll roll out the new encryption protocol to all users by May 30. Not only is the company keeping that promise, it’s doing a wise thing by making the update mandatory so that everyone on Zoom has a uniform and safer experience.

If you haven’t updated to the latest version of Zoom, you can do so by following the steps given here. You can also download the latest app and desktop client by clicking on the button below.


If you’re not familiar with Zoom 5.0 and all the recent security updates made by the platform, you can check out the links below to know more.

Comments
Read comments