Sign Up

Wired issues with mobile data and network

Posted Jan 7, 2018 by arnobde

  1. arnobde

    arnobde Member Scrap Metal

    Messages:
    1
    Likes Received:
    0
    Devices:
    Xiaomi Mi A1
    Outgoing_calls.png SIM_Status.png mobile_data_turned_off.png mobile_data_turned_off.png Mobile_data_turned_on.png I'm looking for some help in figuring out the root cause of the issue as explained. While I'm still pretty confused but I think it might be an issue with the mobile service provider.

    Device: Xiaomi Mi A1 (Android 8.0)

    It all started a few months ago apparently without a cause. If I kept my mobile data turned off initially for a few hours then I can't turn it back on either from the top-down menu(the icon appears but doesn't turn on data) or from the settings. At the same time if I try to make a call then it'll display "Mobile network not available" although I can see full signal reception. This will be solved(temporarily) if I restarted my device or take the SIM slots out and reinserted them (No - turning off/on Airplane mode doesn't work in this case). If I check in settings --> network --> SIM --> It shows 'CARD 1' (without the Service Provider name). Note: I placed it in Slot 1. I tried SIMs from other service providers and didn't observe any such issue.

    Tried doing a full factory reset on my device but no luck. Interestingly I happened to observe the same issue with my Lenovo Vibe P1 (Android 6.0). So I figured it could be a problem with my SIM card, so I got a replacement SIM card issued from the service provider retaining the same number. Frustratingly enough I'm getting the same issue back again. I have explained it to the service provider but I guess they might be as confused as I'm.

    Please see the attached screenshots: (For "Mobile_data_turned_on.jpg" please note that there is still no data/internet connectivity)

    Any help in determining the root cause for such and possible resolution will be much appreciated..!!
     
    Last edited: Jan 7, 2018
  2. TheOracle72

    TheOracle72 Member Droid Minion

    Messages:
    87
    Likes Received:
    18
    Many users including myself had a similar issue with the Redmi Note 3 Pro. My solution was the same as yours which was to switch off the phone and reinsert the sims one by one. My problem came up when I switched the phone back on. I never fully resolved it and now have a Mi Mix2. I suggest you post this in the official Xiaomi forum.
     

Share This Page