Sign Up

My ZTE NUBIA Z9 Mini is somehow dead

Posted Dec 8, 2017 by Manos TS

  1. Manos TS

    Manos TS Member Scrap Metal

    Messages:
    1
    Likes Received:
    0
    Hello, I am new here, I do not know if I post in the right section, so please show understanding.
    I have a ZTE NUBIA Z9 Mini, with no issues to my knowledge so far. Now its like it is dead. Here I note what happened in the last 2 days.
    Wednesday afternoon, my phone was fine. It let a sound warning for low battery at some point. I forgot to charge it, so it shut down. The next morning it did sound the alarm I always set to wake me up - as its supposed to, even when its shut. That indicates it was still working fine.
    Thursday night, before I went to sleep, I had my PC perform defragmentation (OS only) using
    Auslogics DD "defrag and optimize" option, set to shut down after completing the process. After it startedd working on it, I plugged my power drained phone to charge on PC, because couldn't find my adapter for the wall outlet. The phone then showed a red semi circle on the bottom of the screen, blinking on the left end and showing "0%". It looked normal to me.
    I figured the process would last long enough for the phone to charge enough to use it later. I went to sleep right after. Today, Friday, when I tried to boot my phone, it didn't start. I remembered I didn't hear the alarm this morning. Kept trying. No logo, no light, no blinking whatsoever. I supposed it didn't charge last night, so I tried plugging it to the wall, to no effect.
    Then I tried connecting it to PC again and still nothing. A few seconds after I left it plugged, the PC popped a notice followed by an "error" sound. It said "the last device connected did not work properly and cannot be recognized by windows".
    I do not know what to suppose about the issue. The phone was working perfectly until two days ago. I just forgot to charge it after the battery dried out. I thing it was shut for about 16 hours before I plugged it to the PC while it was defragging.
    So my questions are :
    a. what is wrong with my phone?
    b. is the defrag on PC that caused the issue?
    c. can it be fixed?

    Thanks in advance
    d. have others experienced such issue?

    update: today Saturday 10:00 I plugged the phone on the wall using a different charger,it started blinking and now seems to charge. my 1st cable though works fine with my other devices, so I will test it again on the Z9 after its charged.
     
    Last edited: Dec 9, 2017

Share This Page