Sign Up

Screen Overlay detached turn off to allow permissions

Posted Jul 25, 2016 by jleighbrigman

  1. clayto3

    clayto3 Member Drone Droid

    Messages:
    46
    Likes Received:
    0
    Devices:
    Samsung Tab A
    I am fairly new to Android. This problem started a couple of months ago with my Samsung Galaxy Tab A ( I see most contributors have phones so there are some differences for that reason alone). Someone way back suggested waiting for Android to release a fix and here we are a year later still struggling with it, like a disease with different causes, different symptoms, a wide variety of different cures affecting victims in different ways. I have only a couple of the apps suggested as culprits, removing them had no effect.

    Probably the cure for what inflicts my tablet is somewhere in all these posts, but how do I identify it? I am starting to suspect some apps which permanently display floating buttons.
     
  2. Ken Yeung

    Ken Yeung Member Scrap Metal

    Messages:
    1
    Likes Received:
    0
    I want to share my experience. I got the overlay screen problem when I tried to grant the permission to some apps after the Marshmallow update on my BLU phone last week. I followed one of the earlier post's recommendation. I "force stop"ed each of the apps one by one (you can do a group of apps at a time to save time) and granted the permission to see if the problem still existed. At the end, I found the culprit was the ES File Manager. After stopping it, I can grant permission to a number of apps, including WeChat and Google Photo. Hope this can help someone.
     
  3. Stev3m

    Stev3m Member Scrap Metal

    Messages:
    3
    Likes Received:
    0
    I have this same problem on Samsung Note 4 after the recent update. For other reasons I ended up doing a factory reset and re-installing everything, but that didn't fix this particular problem.

    I have turned off the overlay setting for every app on the list, and checked the option to also show system apps and turned it off for them too, and the problem still persists. Also did reboot after turning off the permissions but no change. Also read that Samsung's one-handed mode causes this problem too, but I don't have that turned on. Also read that things that change the screen brightness or colour tone can affect it and I turned off the Samsung settings pertaining to those features too and that didn't fix it.

    Still searching in case someone else has a solution. Will post back here if I find one.
     
  4. Stev3m

    Stev3m Member Scrap Metal

    Messages:
    3
    Likes Received:
    0
    Thanks for that tip - this worked for me too.
     
  5. Stev3m

    Stev3m Member Scrap Metal

    Messages:
    3
    Likes Received:
    0
    OK - below it was suggested that ES File Manager was the culprit - I did Force Stop on it and that did the trick - I can now set new permissions.
     
  6. Sapphire

    Sapphire Member Scrap Metal

    Messages:
    1
    Likes Received:
    0
    THANK YOU! !
    After days of being ready to throw my phone against the wall....I ficed it!!
    Unistalled ALL COOLING, CLEANING APPS, PLUS UPDATES which had automatically been downloaded for Facebook, Samsung Internet etc
    Not sure which app caused the problem but UNINSTALL any recent apps or updates.
    Good luck peops ⚘
     
  7. AbrahamK

    AbrahamK Member Scrap Metal

    Messages:
    1
    Likes Received:
    0
    I had the same issue with my Android 6.01 Samsung Galaxy mobile… I did fix mine.

    When I try launching a new installed app I get the following warning message:

    "Screen overlay detected
    To change this permission
    setting, you first have to turn off
    the screen overlay from Settings
    >Apps"

    Can't continue...

    This worked for me....

    Stopped ES File Explorer app using:
    Home > Settings > Application Manager >
    ES File Explorer >
    Storage
    Clear Cache: Yes
    Clear Data: Yes
    Force Stop: Yes

    Now when I try launching the the app again, it requests permissions without the “Display overlay detected” error getting in the way…

    Hurrah, I can install now more apps...
     
    Last edited: Sep 10, 2017

Share This Page