Sign Up

I don't understand.

Posted Apr 20, 2017 by Nathan Riley

  1. Nathan Riley

    Nathan Riley Member Scrap Metal

    Messages:
    2
    Likes Received:
    0
    Hello, I have a question about the oh-so-famous phrase "Your device is not compatible with this version". I use an older Acer Iconia tab 8(?) With broken power and volume buttons. I got it from a warranty when my old nuvision tablet shattered.The company just gave me a new tablet (at the time the tablet was new). Runs Android 4.4.2, Intel processor with 4 cores, pretty nice.

    I play this game called "Csr Racing 2" it's an amazing (and I mean amazing) high-end game that my tablet can handle with no issues. But, I got a new tablet for Easter, with Android 5.1, and Google play says that the tablet isn't compatible. Big waste of 90-100 dollars.

    Back to the point, does it matter if your device has a newer version of android, or a newer processor and an older version of Android? Because I'm gonna use my money to buy a 150 dollar Samsung tablet, and I don't want to waste my money.

    Thanks for reading!
     
  2. Nathan Riley

    Nathan Riley Member Scrap Metal

    Messages:
    2
    Likes Received:
    0
    If anyone would help that would be great
     

Share This Page